3.phpstudy启动失败的解决方案(MySQL或Apache启动后停止)

潮涌SEO 2017年6月17日22:49:43 评论 11,002

phpstudy apache启动后停止是很多人在使用phpstudy的时候遇到的一个难题,在这一节课我会讲解Apache或MySQL启动失败的原因及其解决方案,此方案同样适用于phpstudy2018apache启动失败。

 

phpstudy启动失败的话,左上角的Apache或MySQL会显示红色小方块,而只有都显示绿色圆点才是启动成功的。

phpstudy启动失败的原因:

  • (1)没有安装VC9运行库(php和apache都是VC9编译的)
  • (2)防火墙拦截
  • (3)80端口已经被别的程序占用,如IIS,迅雷等

 

phpstudy启动失败的几种解决方法:

  • (1)安装vc9运行库(无论你电脑是32位还是64位,只需要安装32位的),32位的VC9运行库下载:
  • (2)关闭IIS,迅雷,360等
  • (3)其他选项菜单-『环境端口检测』进行端口检测,尝试强制启动
  • (3)以管理员身份运行phpstudy
  • (4)重启电脑
  • (5)重装phpstudy,或者把phpstudy安装在电脑的其他磁盘中(默认是D盘,可以安装在E盘、F盘等)
  • (6)安装其他版本的phpstudy,常见版本有:phpStudy2016、phpStudy2018、phpStudyV8(去下载
  • (7)修改端口:『其他选项菜单』-『phpStudy设置』-『端口常规设置』(修改教程

 

仍提示80端口被占用?

 

如有其它问题,请留言

 

关于VC运行库:

php5.3、5.4和apache都是用vc9编译,电脑必须安装vc9运行库才能运行。

php5.5、5.6是vc11编译,如用php5.5、5.6必须安装vc11运行库。

php7.0、7.1是vc14编译,如用php7.0、7.1必须安装vc14运行库。

vc9和vc11运行库下载:

php5.5以上才有64位的,其他均为32位。所以64位的系统最好把32位的运行库也安装上。

如果您下载的是32位的phpStudy,需要安装32位的运行库;32位的VC9运行库必须安装。

注意3点:1、必须安装32位的运行库,2、以管理员身份运行,3、以兼容模式运行。

32位的VC9运行库下载:

 

SEO优化问题咨询
潮涌SEO

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: